如果文章对您有用,麻烦顺手点一下文章的广告吧~

东东

xcode12报错missing one or more architectures required by this target armv7
迫不及待的升级了xcode12,结果在打包的时候报错widget中的一个frameworkmissing one ...
扫描右侧二维码阅读全文
21
2020/09

xcode12报错missing one or more architectures required by this target armv7

迫不及待的升级了xcode12,结果在打包的时候报错widget中的一个framework

missing one or more architectures required by this target armv7

这个只要在打包时把armv7排除掉就行了。

解决方案

在项目TargetBuild Setting中,在Exclude Architectures中,填入armv7就行了,如下图设置。

截屏2020-09-21 下午8.54.23.png

arm版本选择支持

  • arm64 : 必选项,支持iphone5s及以上;最低支持版本:iOS5.1.1
  • armv7s:支持iPhone5及以上;
  • armv7:支持iPhone4及以上;

以上指令集,选择越多,打出来的包就越大;
若抛弃iPhone5s之前的机型,只需要选择arm64即可,这个包是最小的。
若要支持所有iPhone机型,选择armv7、arm64即可。

Last modification:September 21st, 2020 at 09:07 pm
如果觉得我的文章对你有用,请随意打赏: ☞已打赏列表

Leave a Comment